You are not logged in.

1

Thursday, April 26th 2018, 11:01am

Changes to Shops, Upgrading Outdated Browsers

Dear Players,
In order to ensure that we meet current internet security standards, we’re making some changes to our shops which will take effect on 26th April.

Following these changes, outdated browser versions will no longer be supported in our shops. As a result, you may need to upgrade your browser to a more recent version.

If you visit our shops with an outdated browser after 26th April, you will be presented with an error page. We’d therefore like to ask you to upgrade your browser if you aren’t already using the latest version.

The following versions will be supported in future:

• Google Chrome 30-32 or higher
• Mozilla Firefox 27-33 or higher
• Microsoft Internet Explorer Edge, 11 or higher
• Apple Safari 7 or higher
We’d like to thank you for your understanding and hope you continue having fun in our games! Should you have any questions or issues with regard to updating your browser, please contact our Support team.

The Gameforge Team